APP <=> WOOCOMMERCE connection problem

Thank you for your help.

Here the screenshot of the permalinks setting:

but i think the problem is also for this plugin: WooCommerce Permalink Settings

That it configured like that:

Hope this can help you. Thanks again


Can you please add those 3 lines to the htaccess to make the API work regardless the permalink configuration?

RewriteEngine On
RewriteBase /
RewriteRule ^wp-json/(.*) /?rest_route=/$1 [L]

Let me know once done so that I can test

Also what is the use case of this plugin " WooCommerce Permalink Settings " ?

Can you deactivate it and test ?

Hi Bassam, i have add only this row on htaccess:

RewriteRule ^wp-json/(.*) /?rest_route=/$1 [L]

because these others two was there
RewriteEngine On
RewriteBase /

My htaccess now is like this:

the content has been removed for privacy considerations

I also disabled “WooCommerce Permalink Settings” plugin but unfortunately I can’t connect the app to woocommerce :frowning:

Thank you

Hello Bassam Tarek, do you have some news, please? Thanks.

Hello @dralfio

Please take a backup from your .htaccess file and update its content with the below

the content has been removed for privacy considerations

Let me know how it goes

Thank you so much, unfortunately that code generate that error:

Internal Server Error

The server encountered an internal error or misconfiguration and was unable to complete your request.

Please contact the server administrator at to inform them of the time this error occurred, and the actions you performed just before this error.

More information about this error may be available in the server error log.

Additionally, a 500 Internal Server Error error was encountered while trying to use an ErrorDocument to handle the request.

I just updated your plugin to 4.5 version but unfortunately it doesn’t work :frowning:

Do you have staging server that you can give me an access to ? maybe an ssh access to the Wordpress folder ?

no, sorry.

but if you want me to make some changes I’m at your disposal

Let’s schedule a zoom meeting to fix this issue, please send me your available time

for me also now, no problem

Will Tomorrow Monday 2 PM GMT+2 works for you?

ok, thank you so much

@dralfio Waiting for you

The issue was in a plugin setting that was disabling the REST API for Non Admins, once adjusted the system worked normally

Thank you

Hi, unfortunately on Site Health Status i see this error:

The REST API is not behaving correctly Performance

REST APIs are the way WordPress, and other applications, communicate with the server. One example is the block editor screen, which depends on the REST API to view and save your articles and pages.

The REST API did not correctly process the query’s context parameter.

1 Like